Castle Clash: Brave Squads Today: 2    Total Posts: 39205

Total:#5

Create Thread

[Chat (Amazon)] Update borked

[Copy link] 4/489

#1
Posted on 8/22/18 8:22:00 AM | Show thread starter's posts only

Ok, so the update came through on the Amazon app store much quicker than normal. However on launching the game I was stuck at zero percent preparing resources for over 30 minutes. Tried restarting the device and now all I get is a black screen.

Tried uninstalling and reinstalling and I get the same. For kicks I have just installed the Amazon app store on my phone and tried installing and I get exactly the same. So for me at least this is the worst update ever. Will try on my now ancient original Kindle Fire HD later but so far it looks a bust playing Amazon version via their app store on an Android device this time around.

Signature
#2
Posted on 8/22/18 9:50:02 AM | Show thread starter's posts only

This doesn't help you but it worked fine here (Fire HD 8 generation 7).    Most likely sources of such issues are (1) hardware being a little different than what this was tested on, (2) running out of storage and (3) system corruption.

Signature
Guild: Neldy on Android (we are recruiting)
Name: Rusty (Rustyx in game)
Might: ~250k
Guild title: resident wisenheimer.
#3
Posted on 8/22/18 1:18:43 PM | Show thread starter's posts only

[SOLUTION] Go to app settings and give CC all the permissions. I believe storage is the one causing the problem, but I gave it all of them.

Signature

Glitchmaster_PE - Amazon Server - F2P - 120k+ Might
#4
Posted on 8/22/18 7:40:20 PM | Show thread starter's posts only

Mine don't work on my Samsung phone either. Same thing won't load resources. I hope igg has a fix for this. My other account works fine on my kindle. must be non kindle devices

Signature
#5
Posted on 8/23/18 1:14:42 AM | Show thread starter's posts only

Anyone having an issues with merits being returned? I don't think my merits were returned to me after I updated the app.

Signature
oneoftheskilled