Castle Clash: Guild Royale Today: 3    Total Posts: 59681


Create Thread

[Bug] Tapjoy Rewards Failing 100 Percent

[Copy link] 17/1998

Posted on 1/24/18 7:04:01 PM | Show thread starter's posts only

Posting this here since I am not sure where the problem actually is, and I have already contacted Tapjoy about it, also.

The problem:
I run and complete any Tapjoy offer. The reward status is not rewarded and listed as Failed.

The reason (as far as I can tell):
Everything works great... right up to the point it actually tries to deliver gems for a completed offer.

Why I think this is the problem:
I watched several videos. All Failed. I installed and ran an App. Failed. I did the Final Fantasy offer... pending, until I contacted support. Now listed as Failed, I can only presume due to inability to pay out, despite offers being completed. Got a Konami slots offer still pending, which I fully expect to switch to failed once advertiser verification comes in.

Not sure if this is purely a Tapjoy issue, a Castle Clash issue, or some weird combination, so I posted this just in case.

Anyone here having the same problem? Anyone able to actually receive rewards from Tapjoy?

Ok, sure.


Move along, please.
Posted on 1/24/18 7:06:33 PM | Show thread starter's posts only

I usually find your posts and suggestions to be comprehensive and well written.   So I am surprised at how is it that you forgot something as basic as mentioning the platform?

FWIW, I am on Android, just watched a video and got my gem.

Guild: Neldy on Android (we are recruiting)
Name: Rusty (Rustyx in game)
Might: ~520k
Guild title: resident wisenheimer.
Line ID: Rustytroll (big shock there, eh?)
Posted on 1/24/18 7:10:11 PM | Show thread starter's posts only

Android. Kindle doesn't have Tapjoy. Didn't think that iOS or Windows Phone did, either. If they do, my mistake.

Ok, sure.


Move along, please.
Posted on 1/24/18 7:10:41 PM | Show thread starter's posts only

While IGG lists "TapJoy" as a means to obtain free gems they are separate entities.  Any disputes regarding unreceived gems should be directed to TapJoy. It is ultimately their responsibility to inform you as to why the offerings are failing after you have fulfilled your obligations under the offer.  You do of course have the option to contact Live Support for IGG, but I am sure the response will be as given above.


Follow IGG    Follow CC
Posted on 1/24/18 7:20:32 PM | Show thread starter's posts only

I get that they are separated, but Tapjoy can't provide gems to Castle Clash without some kind of coded interface. If Tapjoy is sending the gems, but the Castle Clash side is rejecting that for some reason, that would be on IGG... unless Tapjoy was doing something wrong.

So it could be on either end, or both.

I would think it is probably on Tapjoy's end as well, especially since the Tapjoy interface had changed recently (at least since I last used it), but that isn't guaranteed.

Ok, sure.


Move along, please.
Posted on 1/24/18 7:59:14 PM | Show thread starter's posts only

Let me reply as reply and not comment, since I want to link a pic.   It is working for me.   Here is what I see (and thanks for direction, I didn't know you could do that).   I tried an app and got reward, I tried a video and also got it.   Under "not rewarded", it shows two things I recently tried and never completed, so it says "pending".

So, two questions to start to troubleshoot.

1) Did it work after update but now it is broken?   (basically, did update break it for you or something else?)

2) Do you have another device (phone, tablet, etc) to try?   If it works on another device, something is wrong with your client.   If it fails, something is wrong with your account.

Guild: Neldy on Android (we are recruiting)
Name: Rusty (Rustyx in game)
Might: ~520k
Guild title: resident wisenheimer.
Line ID: Rustytroll (big shock there, eh?)
Posted on 1/24/18 10:43:32 PM | Show thread starter's posts only

Gonna go with a reply instead of a comment, because there is some relevant info that would create an unreadable wall of text, otherwise.

At this point, I have absolutely no idea what the problem could be, because the issue itself has gotten somewhat convoluted in what seems to cause it.

But first, a little background.

I had two devices (excluding Bluestacks), on which I'd used Tapjoy before with no issues. Hadn't used it recently, because Android had been really scarce on the Uncover the Treasure event, so I usually had a pile of gems by the time it came up. So I hadn't used it with this new version of Tapjoy, until the last week or so, when I checked on a whim and saw the two great offers I jumped on.

Well, of those two devices, one still works fine (Samsung Nook device). The other loads a blank wall until you try to move it, the screen loads, but it looks like the old Tapjoy (tiled listings) and none of the offers actually do anything (Asus device). Tapping them gets no response.

Well, I got a new device for Christmas, a phone (Motorola Moto device), which is the device I used to run all the offers on.

Now, as things stand... I can't really diagnose anything. Why? Well...

I tried changing accounts on the Moto device to see if it was maybe my main account that was the issue. Watched a video, and to my surprise I got the reward! Huzzah! Watched another video, just to be sure... Failed. Another, Failed. Tried other accounts on the same device. Failed, over and over.

I have one success for 2 gems mocking me, and numerous failed ones at this point, on the Moto.

So I tried an offer on my Samsung device, on an account that was not the ones having issues. Worked great, so I tried two more. Still good. So I loaded my main account on it (I have different accounts on different devices) and gave it a try. Failed. Switched back to the account I tested with, watched another video, rewarded fine.

Tried the account that worked fine on the Samsung on the Moto. Failed. Tried it on the Samsung again, worked fine.

So I have had:
1. On Moto device, all attempts except one have failed on several different accounts, including accounts that have worked on other devices.
2. On Samsung, all attempts have worked, except for on the main account from the Moto, which failed every time.

So either it's the Moto device AND the main account, or something really weird is going on. But if it is the Moto device, why did it work once, then go back to failing? If it's the accounts, why do accounts that fail on the Moto work on the Samsung, except for that one?

Since the Asus is out for the fact that Tapjoy is pretty well broken there, I couldn't really do anything with that.

But as it stands... I have no idea what could be the problem, anymore. I just know I'm now really frustrated and have a massive headache. :P

Ok, sure.


Move along, please.
Posted on 1/25/18 5:41:38 AM | Show thread starter's posts only

i got same problem.. i think they have a limit for tapjoying

Guild: Phoenix_Uprising
IGN: KuyaKimKong
Might: 181k  
Status: Earn-to-Play
Looking for an account?
Ask Me.
Posted on 1/25/18 12:21:25 PM | Show thread starter's posts only

Interesting stuff right here. I never do tapjoy cause i dont like trash apps piling up my phone storage. Yet the offers lately has been very alluring, but considering about your issue gives me second thoughts though.

Posted on 1/25/18 6:42:36 PM | Show thread starter's posts only

Admittedly, I didn't read everything said in this thread except for the original post.

One thing I have noticed with Tapjoy is that it locks into specific devices.

This may or may not make sense (it doesn't really make sense to me), but if I do Tapjoy on any device other than my primary phone, I will never get the gems (and the offers don't even show up).

If you are doing Tapjoy on a different device (such as a tablet etc), I'm not surprised you aren't getting your gems, and you will have to reach out to Tapjoy themselves.

iOS - DarkKnights