Castle Clash: Brave Squads Today: 3    Total Posts: 56841

Total:#3

Create Thread

[Bug] Quarry in base edit mode and accidentally saving on top of other base designs

[Copy link] 2/190

#1
Posted on 8/9/18 8:38:10 AM | Show thread starter's posts only

The base building edit mode (where you can make 3 bases) is currently working badly with Quarries. When you make a base you drop the quarries where you want them but the base edit mode only remember that exact quarry. If you have planted new quarries after making the base they need to be put into that base before you can swap to it which is inconvenient since you almost always need to plant a quarry before you can swap a base.

On top of this if you have any buildings that have not been put to the base and you try to exit the edit mode it asks if you want to exit without saving. This is not what exiting always does though. If you are coming from layout 2 and you go to layout 3 (which has quarry in reserves) and try to exit it will ask if you want to exit without saving and then after you exit it actually overwrites the whole layout 3 with layout 2.

I know that the quarries are not technically same buildings when they complete so that is why they show as new building in other layout but there should be workarounds to make that work better. The second part is clearly a bug.

Signature
#2
Posted on 8/10/18 12:35:07 AM | Show thread starter's posts only

We shall forward this to our Team and hope the issue u have been facing gets resolved soon. However, Op, If you can for the better understanding of the issue by the team, take a screenshot and post it here? The visual appearance of the glitch will allow the team to excatly pinpoint where the issue is and solve it.

Signature
[left]You are the best for yourself[/left]
#3
Posted on 8/10/18 9:25:27 AM | Show thread starter's posts only

Thank you for the response. Here are the screenshots to explain the glitch of the second part. First part is basically that quarries show up in the edit after you have placed them into the base earlier.

To reproduce the bug you need to: 

-Enter to the edit mode from base layout 2
-Select layout 1
-Have at least 1 building (for example quarry) in the bottom scroll bar
-Exit the mode and press OK. 

When you enter the mode again layout 1 should be replaced with layout 2.

Signature