Castle Clash: Guild Royale Today: 0    Total Posts: 59797


Create Thread

[Bug] Account Switching Bugs (several), Android v1.4.61

[Copy link] 3/630

Posted on 9/1/18 7:16:03 PM | Show thread starter's posts only

I've noticed several bugs with the new account switching system, in the current Android version. For me, including the one or two bug updates that have been made, that is currently v1.4.61.

One of these, number 5 and the last on the list, is a MAJOR problem, in my opinion. I am covering it last, because I want to go into why I think it is a major problem and why I think it needs to be fixed IMMEDIATELY.

1. This is, of course, the first bug most have noticed: the game not properly loading game information.

Information not loaded correctly includes, but is not necessarily limited to, guild information, friends list, and so on, which is most evident by the "loading" label in place of the Guild Name on the Guild Hall.

This has been noted numerous times since the last update, but I include it again due to the fact that, for some of us, it is highly annoying and problematic.

During the last Torch Battle, I had to re-load the game a total of six times in a row, on the same account, before it finally loaded properly so that I could haul.

This bug is one that I had never seen, prior to the last update.

2. Account switching sometimes fails, but the game acts like it worked.

For example, I am on account A. I go switch to account B. It seems like everything worked fine, no errors or anything like that. When the game finishes loading, I am still on account A... but when I go to switch again, since I'm not on the account I want to be on, the nameplate that tells which account I'm on says I am on account B.

This is a nuisance, much like number 1. It can be resolved by continuing to switch until it works properly.

This bug is one that I had never seen, prior to the last update.

3. Account switching sometimes asks twice.

What I mean by that is that you go to switch, select the account you want to switch to, and then hit the confirmation button. Then, instead of switching, it pops the list up a second time and makes you choose again.

In my experience, this has never asked three times, only twice.

This bug is one that I had never seen, prior to the last update.

4. Account switching sometimes picks another account on your device, instead.

For example, say I have three accounts on my device. Why three? Well, with less than three accounts this can appear to be bug number 2.

So I have three accounts on my device, which we'll label the ever creative A, B, and C.

A is my main account. B is a Smurf, and C is yet another Smurf.

So I'm on account A and I decide to switch to account C. Sometimes, the game will instead switch to account B for no apparent reason. The account it randomly switches to is always the same one, by the way.

I have tried to narrow down why it does it and why it picks this one account to randomly say, "No, you wanted this one!" I have yet to work out either.

The times it happens seem completely random. There is nothing that I've noticed that seems to precede it.

As for the account it chooses, for a while I thought it was whatever the guest account was. On my new device it isn't the guest account, though, but the last one I made. So I'm back to square one on why it picks this random account as it's "correction" target.

I have seen this bug prior to the last update, but it seemed to come and go between updates. By that I mean in some updates it happened regularly. Then the next update it would seemingly vanish.

And I've saved the "best" for last:

5. (MAJOR) Sometimes, account switching will switch to an entirely unknown account not connected to the device or user in any known way. Yes, you read that correctly.

EDIT: Downgraded this from MAJOR to regular bug, since the account that was not mine was in fact a NEW Guest account that was apparently created when the new Account Switching System was added. This bug may, instead, simply be an instance of Bug 4 changing targets due to the change in the account switching system. I have left the information below, just in case, but this appears to be another nuisance bug, rather than the major security hazard I first thought.

I have, on multiple occasions since this last update, tried to switch and ended up on an account that WAS NOT MINE.

In my case, it was an account with literally no name (the name section was entirely blank), had only been started and apparently never played (the tutorial wasn't even completed and I ended up hiring the first Executioner on it, because the tutorial started in), was under 500 might, and was still spitting out the new player chests for the first seven logins.

I left the account alone, once I confirmed it WAS NOT MINE, and switched away. I thought it might have been a one time thing. Nope. Happened two more times, since.

Interestingly enough, it was the exact same account it switched to, every time... so the damage there is likely relatively contained, since it appears that someone can't switch accounts until it happens and wreck a different person's account every time.

That still leaves me worried that someone is going to end up switching onto one of mine, through this bug, and destroying my hard work. So I think this needs to be found and fixed IMMEDIATELY, for the security of everyone's accounts.

This particular bug has only been introduced since the last update, as far as I can tell. I have never once had this happen to me, prior to that. Since the last update, it's happened three separate times on three separate days.

That about does it for me, for now. If I find anything more I'll try to add it here.

Has anyone else noticed any or all of these bugs?

Ok, sure.


Move along, please.
Posted on 9/1/18 7:43:52 PM | Show thread starter's posts only

Do you have a guest login when you switch?  What you describe with #5 sounds a lot like logging into guest login.

I have a single real account on my phone/Bluestacks setup, but I also have guest login on both.  Once in a while game fails to properly load my real account and loads guest account instead.  And since I never play it, it was same as you described - going into tutorial.   And once I went through it, it just sits at that point where you regain control of the game after tutorial.

It is same account every time (I wrote down the IGG ID) and it also has no name.   It is not linked to any email, so presumably IGG could decide to give it to someone else.   They just never did, on either of my devices.

Maybe that happened to you for first time.   If so, you should not worry.   It has been happening to me every month or so, and it doesn't cause problems.   Your main account and IGG ID are linked to email, and nobody should be able to get it.

Guild: Neldy on Android (we are recruiting)
Name: Rusty (Rustyx in game)
Might: ~520k
Guild title: resident wisenheimer.
Line ID: Rustytroll (big shock there, eh?)
Posted on 9/1/18 8:34:05 PM | Show thread starter's posts only

When I got my new device and logged in for the first time, it made a new account (I had to go through the tutorial just to get at the switch button, because I couldn't find a way to skip it), which I proceeded to link to a new Google account.

All accounts I've made in Castle Clash have been linked, except for the ones for Kindle/Amazon... and those have only not been linked due to the fact that it's not an option there, despite the somewhat humorous mention in the login tips to link the account to your Google account. :D

Anyway, whenever I switched to the Guest account, it always brought up that first account I Linked after getting the new device. Of course, this was all prior to the new account system being added, so I didn't even think to check that was still the case.

I just checked it, and lo and behold, the Guest account is no longer the first account I made on my device. It is now an entirely different account, which I had never seen before and is in fact the one I've been somehow being logged into at random.

That means that this may, in fact, just be another instance of bug 4 and it has just changed its target from its old target (which was not the Guest account) to that new Guest account, since the new system was added. Because now that I think about it, I don't think I've seen it switch to that last account I made since the last update came in.

Thanks for the suggestion, though, as that allows me to feel relatively safe in downgrading this from a major bug with potentially catastrophic results to just another minor nuisance in the system that I can breathe easier about. :)

Ok, sure.


Move along, please.
Posted on 9/1/18 8:57:30 PM | Show thread starter's posts only

Slightly off topic: can you have more than one game account per email address, or do you have to use separate emails for the different accounts? Thank you

2Crazy4U, 2Crazy, 2C, Bob ... it is all the same. I am F2P and proud of it.
Always looking for new members in my laid-back guild: 2Crazy4U