Castle Clash: Guild Royale Today: 0    Total Posts: 44238


Create Thread

[News] We Released Version 1.7.62 to Fix AMA Update Issue

[Copy link] 9/3398

Posted on 5/22/20 5:27:23 AM | Show thread starter's posts only

Regarding the update issue on Amazon, we sincerely apologize for the inconveninece caused. Dev team has been working on it. And thanks to your feedback, a new version 1.7.62 is released in order to fix it. Please use the following link to download. We appreciate your kind understanding and cooperation. 


Please let me know if it works or not. Thanks!

cc_with_jenkins has tried and it worked. You may please follow his guidance:
Amazon Server Update Issue Fixed

1. To allow the apk file of the patch to be installed, make sure that the 'Allow installation from unknown sources' is turned on, it is located in settings under device. 
2. But before you install it, make sure you delete the old version of Castle Clash from cloud so that the file New version can replace it. 
3. Once installed, you can open it via Download list located in the Silk Browser or your Apps list. 
4. Allow installation from unknown sources can be turned off once installation has concluded.

Posted on 5/22/20 7:40:23 AM | Show thread starter's posts only

Does not work

Posted on 5/22/20 8:33:39 AM | Show thread starter's posts only

Worked for me. Just need to get account restored

Posted on 5/22/20 12:08:45 PM | Show thread starter's posts only

Did not work for me .  Completed the process of installing and it says app is not installed.

Posted on 5/23/20 12:39:53 AM | Show thread starter's posts only

Posted on 5/23/20 4:40:51 AM | Show thread starter's posts only

I also have been trying to get the update for days.  I have uninstalled, reinstalled, tried all the "fixes".....nothing!!!! In the meantime missing a lot of stuff (Narcia, Guild Wars....etc..)  Very frustrating

Posted on 5/24/20 6:27:13 AM | Show thread starter's posts only

I downloaded and ran. But it cannot work.

Posted on 5/24/20 11:41:48 AM | Show thread starter's posts only

It worked for me. Thanks but I can't purchase anything from bazaar packs/gems. Any help on that? Also is there any news on the app being released on the amazon/kindle app store again? I don't want another apk update and neither does the community.

Posted on 5/25/20 9:15:58 AM | Show thread starter's posts only

this apk didn't work but they have updated the Amazon app store and when downloaded through it.  the game worked albeit I had to download and install the game 3 times to get it to open.   but now it works.  it's a shame they break game integrity by temporarily not allowing some accts to update.  lots of resources were lost.  but now i can play it.  thanks to all that helped and reported.

Posted on 6/1/20 10:32:17 AM | Show thread starter's posts only

This thread has been banned.