Castle Clash: Guild Royale Today: 0    Total Posts: 13883


Create Thread

[Chat (WP)] i can not download the update or game App from the windows store

[Copy link] 2/1324

Posted on 8/27/17 7:05:57 AM | Show thread starter's posts only

I've been unable to download the update, if and when it would start it would get to about 30% and stop and remain at pending. i sat and waited a little over 24 hours and its still on pending.

well after it continued failing to download i went ahead and uninstalled the app and tried to download again. same results it goes directly to pending, sometimes it actually starts but again only gets to around 30% and stops and goes back to pending.

i got fed up and did a factory reset and tried again, and still no luck.

see the odd thing is that i can download other apps and games just fine on the windows store, just not castle clash. 

the phone is a nokia lumia 1320 running windows 8.1, its no longer used as a phone and its only used for this game because the "servers are different" then the android servers. i really wish i could get them to transfer my account over to android so i could do away with this darn windows phone. i know its not my internet or the phone causing the issue because like i said above i can download other apps and games on the windows store without any issue.

i got into contact with support over email, i contacted the support for the windows phone version, for some odd reason they do not read the emails as i told them what email is linked to my account but yet they continue to use the email from where i'm emailing them from instead of going by what i said in the email. i use my Gmail email to email from, i do not use my hotmail email account except for Microsoft accounts and services.

Posted on 8/27/17 9:42:34 AM | Show thread starter's posts only

That used to happen to me. you can only  wait and  hope its downlaods after a while.

[left]You are the best for yourself[/left]
Posted on 8/29/17 1:42:22 AM | Show thread starter's posts only

You can try Googling "Windows Phone pending download" and see if it brings up any solutions. Mine stuck once a long time ago and I think it had something to do with the Daylights Saving setting for me.